re = /(?:a{3}(?!a(?:[^a]|$))|a{2})/m
str = 'aa
aaa
aaaa
aaaaa
aaaaaa
aaaaaaa
aaaaaaaa
aaaaaaaaa
aaaaaaaaaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end