using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\/([^\/,\s]+\.[^\/,\s]+?)(?=\/|,|\s|$|\?|#)";
string input = @"https://www.google.com/hello/hi.php, http://youtube.com, http://test.net#jump or http://google.com?q=test";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}