$re = '/\/\/([^\/,\s]+\.[^\/,\s]+?)(?=\/|,|\s|$|\?|#)/';
$str = 'https://www.google.com/hello/hi.php, http://youtube.com, http://test.net#jump or http://google.com?q=test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);