#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?[0-9]{0,5}?(\.[0-9]{1,2})?$"
Local $sString = "Valid" & @CRLF & _
"-1" & @CRLF & _
"+1" & @CRLF & _
"1" & @CRLF & _
".1" & @CRLF & _
"-.1" & @CRLF & _
".1" & @CRLF & _
"+11111.11" & @CRLF & _
"-11111.11" & @CRLF & _
"11111" & @CRLF & _
"" & @CRLF & _
"Invalid" & @CRLF & _
"+111111.11" & @CRLF & _
"-111111.11" & @CRLF & _
"+11111.111" & @CRLF & _
"-11111.111" & @CRLF & _
"11111.111" & @CRLF & _
"111111.11" & @CRLF & _
"+1." & @CRLF & _
"-1." & @CRLF & _
"1."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")