$re = '/^[+-]?[0-9]{0,5}?(\.[0-9]{1,2})?$/m';
$str = 'Valid
-1
+1
1
.1
-.1
.1
+11111.11
-11111.11
11111
Invalid
+111111.11
-111111.11
+11111.111
-11111.111
11111.111
111111.11
+1.
-1.
1.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);