const regex = /^(?!.*grep)(?=.*mysql).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*grep)(?=.*mysql).*', '')
const str = `root 28012 0.0 0.1 4408 712 pts/0 S 18:00 0:00 /bin/sh /usr/bin/mysqld_safe
root 29062 0.0 0.1 9392 900 pts/1 S+ 20:21 0:00 grep --color=auto mysqld_safe
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}