$re = '/^(?!.*grep)(?=.*mysql).*/';
$str = 'root 28012 0.0 0.1 4408 712 pts/0 S 18:00 0:00 /bin/sh /usr/bin/mysqld_safe
root 29062 0.0 0.1 9392 900 pts/1 S+ 20:21 0:00 grep --color=auto mysqld_safe
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);