use strict;
my $str = '1000\\03-01
1009/01\\09
1090-12/10
1099-11-11
1900\\31/19
1909\\14\\20
1999-10\\21
2011/29
2001-30
2012-04';
my $regex = qr/(?<=\s|^)(1[0-9]{3}|20(0[0-9]|1[0-2]))[\\\/\-\s](0[1-9]|1[0-2])[\\\/\-\s](0[1-9]|[1-2][0-9]|30)(?=[\s,;]|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}