import Foundation
let pattern = #"(?<=\s|^)(1[0-9]{3}|20(0[0-9]|1[0-2]))[\\\/\-\s](0[1-9]|1[0-2])[\\\/\-\s](0[1-9]|[1-2][0-9]|30)(?=[\s,;]|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1000\03-01
1009/01\09
1090-12/10
1099-11-11
1900\31/19
1909\14\20
1999-10\21
2011/29
2001-30
2012-04
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)