import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)\n"
+ "(?:\n"
+ " ^ \\d{2} - \\d{4} [^|\\r\\n]* \\| \n"
+ " | \\G \n"
+ ")\n"
+ "(?: [^|\\r\\n]* \\| )*\n"
+ "\\K \n"
+ "[\\r\\n]+ (?! [\\r\\n]* (?: ^ \\d{2} - \\d{4} | $ ) )\n";
final String string = "00-1234T|\n"
+ "Data|Commments|\n"
+ "12-3456|Some data|Notes|\n"
+ "65-8436ZZ|Data|\n"
+ "|\n"
+ "45-4576AA|Some data|Comments|\n"
+ "98-4392REV|Data|\n"
+ "|\n"
+ "00-5432|Some Data|Some Comments|\n";
final String subst = "#CRLF#";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}