// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?m)
(?:
^ \d{2} - \d{4} [^|\r\n]* \|
| \G
)
(?: [^|\r\n]* \| )*
\K
[\r\n]+ (?! [\r\n]* (?: ^ \d{2} - \d{4} | $ ) )
").unwrap();
let string = "00-1234T|
Data|Commments|
12-3456|Some data|Notes|
65-8436ZZ|Data|
|
45-4576AA|Some data|Comments|
98-4392REV|Data|
|
00-5432|Some Data|Some Comments|
";
let substitution = "#CRLF#";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}