const regex = /<([a-z]+) .*=".*">/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([a-z]+) .*=".*">', 'g')
const str = `1|<table attribute="1">
2|<tbody attribute="2">
3|<tr unwanted_attribute="3"><td unwanted_attribute="3"><br unwanted_attribute="3" /></td></tr>
4|<tr unwanted_attribute="3"><td unwanted_attribute="3"><span unwanted_attribute="3"></span></td></tr>
5|</tbody>
6|</table>`;
const subst = `<\1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);