re = /<([a-z]+) .*=".*">/
str = '1|<table attribute="1">
2|<tbody attribute="2">
3|<tr unwanted_attribute="3"><td unwanted_attribute="3"><br unwanted_attribute="3" /></td></tr>
4|<tr unwanted_attribute="3"><td unwanted_attribute="3"><span unwanted_attribute="3"></span></td></tr>
5|</tbody>
6|</table>'
subst = '<\\1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result