package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^>]*>`)
var str = `<ANY>
some STUFF here
Obary SEES Obary
</ANY>
<SOME>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}