#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<img.*?src\s*=\s*"([^"]*\?contextId[^"]*)"
Local $sString = "<img xmlns="http://www.w3.org/1999/xhtml" src="http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier" alt="Bild Übersicht Router" title="Übersicht Router" />" & @CRLF & _
"" & @CRLF & _
"<p> sdfs </p>" & @CRLF & _
"" & @CRLF & _
"<img xmlns="http://www.w3.org/1999/xhtml" src="http://localhost:8080/resource/carl/eService/rain/apple.png?contextId=eservice_aaa" alt="Communicator" title="Super Robot" />" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")