# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img.*?src\s*=\s*\"([^\"]*\?contextId[^\"]*)"
test_str = ("<img xmlns=\"http://www.w3.org/1999/xhtml\" src=\"http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier\" alt=\"Bild Übersicht Router\" title=\"Übersicht Router\" />\n\n"
"<p> sdfs </p>\n\n"
"<img xmlns=\"http://www.w3.org/1999/xhtml\" src=\"http://localhost:8080/resource/carl/eService/rain/apple.png?contextId=eservice_aaa\" alt=\"Communicator\" title=\"Super Robot\" />\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.