import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'(\\\\x[0-9a-fA-F]{2}|\\\\u[0-9a-fA-F]{4})*'";
final String string = "'\\x0F'\n"
+ "'\\u0fff'\n"
+ "'23'\n"
+ "'teset'\n"
+ "'wer.fee'\n\n"
+ "'\\x0FF'\n"
+ "'\\u0fff\\x'\n"
+ "'\\u0fff\\'\\'\n"
+ "'\\u0fff\"'\n"
+ "'\\u0fff\\b'\n"
+ "'\\u0fff\\f'\n"
+ "'\\u0fff\\n'\n"
+ "'\\u0fff\\r'\n"
+ "'\\u0fff\\t'\n"
+ "'\\u0fff\\v'\n"
+ "'\\u0fff\\n'\n"
+ "'\\u0fff\\\\'\n"
+ "'\\u0fff\\r'\n"
+ "'\\u0fff\\\\u2028'\n"
+ "'\\u0fff\\\\u2029'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}