package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\W(\.([\w_]+))`)
var str = ` <style>
.tblGenFixed td {
padding: 0 3px;
overflow: hidden;
white-space: normal;
letter-spacing: 0;
word-spacing: 0;
background-color: #fff;
z-index: 1;
border-top: 0px none;
border-left: 0px none;
border-bottom: 1px solid #CCC;
border-right: 1px solid #CCC;
}
.dn {
display: none
}
.tblGenFixed td.s0 {
background-color: #000000;
font-family: arial, sans, sans-serif;
font-size: 120.0%;
font-weight: bold;
font-style: normal;
color: #ffffff;
text-decoration: none;
text-align: left;
vertical-align: bottom;
direction: auto-ltr;
white-space: normal;
overflow: hidden;
border-top: 1px solid #CCC;
border-right: ;
border-bottom: ;
border-left: 1px solid #CCC;
}
</style>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}