# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\W(\.([\w_]+))"
test_str = (" <style>\n"
" .tblGenFixed td {\n"
" padding: 0 3px;\n"
" overflow: hidden;\n"
" white-space: normal;\n"
" letter-spacing: 0;\n"
" word-spacing: 0;\n"
" background-color: #fff;\n"
" z-index: 1;\n"
" border-top: 0px none;\n"
" border-left: 0px none;\n"
" border-bottom: 1px solid #CCC;\n"
" border-right: 1px solid #CCC;\n"
" }\n"
" .dn {\n"
" display: none\n"
" }\n"
" .tblGenFixed td.s0 {\n"
" background-color: #000000;\n"
" font-family: arial, sans, sans-serif;\n"
" font-size: 120.0%;\n"
" font-weight: bold;\n"
" font-style: normal;\n"
" color: #ffffff;\n"
" text-decoration: none;\n"
" text-align: left;\n"
" vertical-align: bottom;\n"
" direction: auto-ltr;\n"
" white-space: normal;\n"
" overflow: hidden;\n"
" border-top: 1px solid #CCC;\n"
" border-right: ;\n"
" border-bottom: ;\n"
" border-left: 1px solid #CCC;\n"
" }\n"
"</style>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.