package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Z]:\(?:\w+\\?)*$`)
var str = `C
C:
C:/
C://
C:\
C:\\
C:\Documents\Newsletters\Summer2018.pdf
\Program Files\Custom Utilities\StringFinder.exe
2018\January.xlsx
..\Publications\TravelBrochure.pdf
C:\Projects\apilibrary\apilibrary.sln
C:Projects\apilibrary\apilibrary.sln
\\system07\C$\
\\Server2\Share\Test\Foo.txt
\\.\C:\Test\Foo.txt
\\?\C:\Test\Foo.txt
C:\utilities\filecompare\
c:\utilities\filecompare\
\\Server\Share
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}