re = /^[a-zA-Z]:\(?:\w+\\?)*$/
str = 'C
C:
C:/
C://
C:\\
C:\\\\
C:\\Documents\\Newsletters\\Summer2018.pdf
\\Program Files\\Custom Utilities\\StringFinder.exe
2018\\January.xlsx
..\\Publications\\TravelBrochure.pdf
C:\\Projects\\apilibrary\\apilibrary.sln
C:Projects\\apilibrary\\apilibrary.sln
\\\\system07\\C$\\
\\\\Server2\\Share\\Test\\Foo.txt
\\\\.\\C:\\Test\\Foo.txt
\\\\?\\C:\\Test\\Foo.txt
C:\\utilities\\filecompare\\
c:\\utilities\\filecompare\\
\\\\Server\\Share
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end