const regex = new RegExp('.', 'gm')
const str = `fgh`;
const subst = `+$\`$&'$'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);