import re
regex = re.compile(r".", flags=re.MULTILINE)
test_str = "fgh"
subst = "+$`$&'$'"
result = regex.sub(subst, test_str)
if result:
print(result)