$re = '/__[A-Z0-9_]+__\(\s*(?:\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'|\d+)(?:\s*,\s*(?:\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'|\d+))*\s*\)/m';
$str = '5 + __FXN1__(\'hello\', 1, 3, \'__HELLO__(\\\'hello\\\') + 5\') + 5 + (2/2) + __FXN2__(\'Good boy\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);