const regex = /([^\s]+)\s?(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s]+)\\s?(.*)', '')
const str = `#ud %+^'()=%^'K%J+^K\$#££½6 u896%+& 547900`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}