using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!(?!(.|\n|\r)*FastEthernet\d\d?\/\d\d?\.\d{1,3})";
string input = @"interface FastEthernet0/0
shutdown
!
interface FastEthernet0/0.100
ip address 192.168.1.100
!
interface FastEthernet0/1
shutdown
!";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}