$re = '/^.*-([0-9]{2,4})\b.*/m';
$str = 'ABC-L-W7P-1423
ABC-L-W7E-87
CH-L-W7-756
CH-M-311-MM';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;