# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*-([0-9]{2,4})\b.*"
test_str = ("ABC-L-W7P-1423\n"
"ABC-L-W7E-87\n"
"CH-L-W7-756\n"
"CH-M-311-MM")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.