#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^0-9]+"
Local $sString = "dA/Sa" & @CRLF & _
"dAS2a" & @CRLF & _
"dASI/" & @CRLF & _
"dASI6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")