$re = '/[^0-9]+/';
$str = 'dA/Sa
dAS2a
dASI/
dASI6';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);