using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\S)\s+(?=(?:\d+\.\d+|optimised)\b)";
string input = @" 23.32 | x232 code | This is a description| 43.11 | a341 code | some other description | optimised | v333 code | still another description";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}