$re = '/(?<=\S)\s+(?=(?:\d+\.\d+|optimised)\b)/m';
$str = ' 23.32 | x232 code | This is a description| 43.11 | a341 code | some other description | optimised | v333 code | still another description';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);