using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:if|for|while|foreach|catch|switch|try ?)\(((?>[^\(\)]+)|(?R))*\)";
string input = @"if(true)
if(true)
if(true)
echo '';
if (true)
echo 'true';
elseif (false)
echo 'false';
else
echo 'neither?';
for(true)
echo '';
foreach (true) {
echo '';
}
if (true || true && (false || true)
|| true)
echo '';
while (true)
{
echo '';
}
if (true)
{
echo '';
}
for(true)
{
echo '';
}
try
{
echo '';
}
if (true || true && (false || true)
|| true) {
echo '';
}
for(true)
{
echo '';
}
if (true) {
echo '';
}
for(true)
{
echo '';
}
foreach(true)
{
echo '';
}
while(true)
{
echo '';
}
catch(true)
{
echo '';
}
switch(true)
{
echo '';
}
try {
echo '';
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}