const regex = /(?:if|for|while|foreach|catch|switch|try ?)\(((?>[^\(\)]+)|(?R))*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:if|for|while|foreach|catch|switch|try ?)\\(((?>[^\\(\\)]+)|(?R))*\\)', 'gm')
const str = `if(true)
if(true)
if(true)
echo '';
if (true)
echo 'true';
elseif (false)
echo 'false';
else
echo 'neither?';
for(true)
echo '';
foreach (true) {
echo '';
}
if (true || true && (false || true)
|| true)
echo '';
while (true)
{
echo '';
}
if (true)
{
echo '';
}
for(true)
{
echo '';
}
try
{
echo '';
}
if (true || true && (false || true)
|| true) {
echo '';
}
for(true)
{
echo '';
}
if (true) {
echo '';
}
for(true)
{
echo '';
}
foreach(true)
{
echo '';
}
while(true)
{
echo '';
}
catch(true)
{
echo '';
}
switch(true)
{
echo '';
}
try {
echo '';
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}