using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9!#$%&’*+\/=?^_`{|}~.-]+@([a-zA-Z0-9\\-]+\.)*([a-zA-Z]){2,}$";
string input = @"ab@ab";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}