re = /^[a-zA-Z0-9!#$%&’*+\/=?^_`{|}~.-]+@([a-zA-Z0-9\\-]+\.)*([a-zA-Z]){2,}$/
str = 'ab@ab'
# Print the match result
str.match(re) do |match|
puts match.to_s
end