#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(where|and|or)\s*([^\s=]*?)\s*(=|<>|>=|=<|>|<)\s*("|'|\\"|\\')([^\4]*?)\4"
Local $sString = "REPLACE active_watchers_log SET sent_msg="NOTIFY sip:995582134@192.168.26.5:5062 SIP/2.0" & @CRLF & _
"Via: SIP/2.0/UDP 10.23.0.2;branch=z9hG4bKfd9d.445c5656000000000000000000000000.0" & @CRLF & _
"To: <sip:995582134@teste.sip.90e9.com>;tag=89b8ace0d56977e7" & @CRLF & _
"From: <sip:user_7z7b6s@teste.sip.90e9.com>;tag=9e489e1f14886363a3aeebf53b8dbf2c-4976" & @CRLF & _
"CSeq: 34 NOTIFY" & @CRLF & _
"Call-ID: bec506c8-48da1ac1@192.168.26.5" & @CRLF & _
"Content-Length: 277" & @CRLF & _
"Max-Forwards: 70" & @CRLF & _
"Event: dialog" & @CRLF & _
"Contact: <sip:10.23.0.2:5060;transport=udp>" & @CRLF & _
"Subscription-State: active;expires=600" & @CRLF & _
"Content-Type: application/dialog-info+xml" & @CRLF & _
"" & @CRLF & _
"<?xml version=\"1.0\"?>" & @CRLF & _
"<dialog-info xmlns=\"urn:ietf:params:xml:ns:dialog-info\" version=\"34\" state=\"full\" entity=\"sip:user_7z7b6s@teste.sip.90e9.com\">" & @CRLF & _
" <dialog id=\"615293b33c62dec073e05d9421e9f48b\" direction=\"recipient\">" & @CRLF & _
" <state>terminated</state>" & @CRLF & _
" </dialog>" & @CRLF & _
"</dialog-info>" & @CRLF & _
"", received_msg="SIP/2.0 200 OK" & @CRLF & _
"To: <sip:995582134@teste.sip.90e9.com>;tag=89b8ace0d56977e7" & @CRLF & _
"From: <sip:user_7z7b6s@teste.sip.90e9.com>;tag=9e489e1f14886363a3aeebf53b8dbf2c-4976" & @CRLF & _
"Call-ID: bec506c8-48da1ac1@192.168.26.5" & @CRLF & _
"CSeq: 34 NOTIFY" & @CRLF & _
"Via: SIP/2.0/UDP 10.23.0.2;branch=z9hG4bKfd9d.445c5656000000000000000000000000.0" & @CRLF & _
"Server: Cisco/SPA504G-7.6.0" & @CRLF & _
"Content-Length: 0" & @CRLF & _
"" & @CRLF & _
"", time=1453481591, result=200 where pres_uri="sip:user_7z7b6s@teste.sip.90e9.com" and callid="bec506c8-48da1ac1@192.168.26.5" and watcher_user=\"995582134\" and watcher_domain=\'teste.sip.90e9.com\' and to_user="user_7z7b6s" and to_domain="teste.sip.90e9.com""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")