import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(where|and|or)\\s*([^\\s=]*?)\\s*(=|<>|>=|=<|>|<)\\s*(\"|'|\\\\\"|\\\\')([^\\4]*?)\\4";
final String string = "REPLACE active_watchers_log SET sent_msg=\"NOTIFY sip:995582134@192.168.26.5:5062 SIP/2.0\n"
+ "Via: SIP/2.0/UDP 10.23.0.2;branch=z9hG4bKfd9d.445c5656000000000000000000000000.0\n"
+ "To: <sip:995582134@teste.sip.90e9.com>;tag=89b8ace0d56977e7\n"
+ "From: <sip:user_7z7b6s@teste.sip.90e9.com>;tag=9e489e1f14886363a3aeebf53b8dbf2c-4976\n"
+ "CSeq: 34 NOTIFY\n"
+ "Call-ID: bec506c8-48da1ac1@192.168.26.5\n"
+ "Content-Length: 277\n"
+ "Max-Forwards: 70\n"
+ "Event: dialog\n"
+ "Contact: <sip:10.23.0.2:5060;transport=udp>\n"
+ "Subscription-State: active;expires=600\n"
+ "Content-Type: application/dialog-info+xml\n\n"
+ "<?xml version=\\\"1.0\\\"?>\n"
+ "<dialog-info xmlns=\\\"urn:ietf:params:xml:ns:dialog-info\\\" version=\\\"34\\\" state=\\\"full\\\" entity=\\\"sip:user_7z7b6s@teste.sip.90e9.com\\\">\n"
+ " <dialog id=\\\"615293b33c62dec073e05d9421e9f48b\\\" direction=\\\"recipient\\\">\n"
+ " <state>terminated</state>\n"
+ " </dialog>\n"
+ "</dialog-info>\n"
+ "\", received_msg=\"SIP/2.0 200 OK\n"
+ "To: <sip:995582134@teste.sip.90e9.com>;tag=89b8ace0d56977e7\n"
+ "From: <sip:user_7z7b6s@teste.sip.90e9.com>;tag=9e489e1f14886363a3aeebf53b8dbf2c-4976\n"
+ "Call-ID: bec506c8-48da1ac1@192.168.26.5\n"
+ "CSeq: 34 NOTIFY\n"
+ "Via: SIP/2.0/UDP 10.23.0.2;branch=z9hG4bKfd9d.445c5656000000000000000000000000.0\n"
+ "Server: Cisco/SPA504G-7.6.0\n"
+ "Content-Length: 0\n\n"
+ "\", time=1453481591, result=200 where pres_uri=\"sip:user_7z7b6s@teste.sip.90e9.com\" and callid=\"bec506c8-48da1ac1@192.168.26.5\" and watcher_user=\\\"995582134\\\" and watcher_domain=\\'teste.sip.90e9.com\\' and to_user=\"user_7z7b6s\" and to_domain=\"teste.sip.90e9.com\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}