const regex = /(?:^|\n)([^:]+):|(?:\s?)([^,\n]+)(?:,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\n)([^:]+):|(?:\\s?)([^,\\n]+)(?:,|$)', 'gm')
const str = `Prompt: professional digital [airbrush:gouache:0.6] art of 20 year old (mythical:1.1) demon with long black hair, wearing ragged jacket and jeans, dynamic lighting, outstanding, masterpiece, cinematic, best, perfect, slightly blurry fantasy country background, rule of thirds, composed
Negative prompt: (child), (male), (mangled hands), (badly drawn hands),( badly drawn fingers), back turned
Template: professional digital [airbrush:gouache:0.6] art of {20¦30} year old (mythical:1.1) demon with {medium|long} {brown|black} hair, wearing ragged jacket and jeans, dynamic lighting, outstanding, masterpiece, cinematic, best, perfect, slightly blurry fantasy {office¦country¦castle} background, rule of thirds, composed
Negative Template: (child), (male), (mangled hands), (badly drawn hands),( badly drawn fingers), back turned`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}