import re
regex = re.compile(r"(?:^|\n)([^:]+):|(?:\s?)([^,\n]+)(?:,|$)", flags=re.MULTILINE)
test_str = ("Prompt: professional digital [airbrush:gouache:0.6] art of 20 year old (mythical:1.1) demon with long black hair, wearing ragged jacket and jeans, dynamic lighting, outstanding, masterpiece, cinematic, best, perfect, slightly blurry fantasy country background, rule of thirds, composed\n"
"Negative prompt: (child), (male), (mangled hands), (badly drawn hands),( badly drawn fingers), back turned\n"
"Template: professional digital [airbrush:gouache:0.6] art of {20¦30} year old (mythical:1.1) demon with {medium|long} {brown|black} hair, wearing ragged jacket and jeans, dynamic lighting, outstanding, masterpiece, cinematic, best, perfect, slightly blurry fantasy {office¦country¦castle} background, rule of thirds, composed\n"
"Negative Template: (child), (male), (mangled hands), (badly drawn hands),( badly drawn fingers), back turned")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")