import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?[\\d\\w\\.-]+(?:\\.|:)(?:[a-z\\.]{2,6}|\\d+)\\/?.*$";
final String string = "https://regex101.com/\n"
+ "https://www.variables.sh/complex-regular-expression-examples\n"
+ "https://search.brave.com/search?q=regex+challenges&source=desktop\n"
+ "https://web.whatsapp.com/\n"
+ "https://www.youtube.com/watch?v=fc_RvxTtIwc\n"
+ "https://text-auditor.netlify.app/\n"
+ "https://github.com/Dashrath-Sharma\n"
+ "http://github.com/Dashrath-Sharma\n"
+ "https://onecompiler.com/javascript/3zqzyu2g4\n"
+ "http://localhost:3000/\n"
+ "https://www.codingame.com/clashofcode/clash/report/3342454a92e4c660d772438bac8b2ef73de3c8f\n"
+ "https://react.dev/learn/thinking-in-react\n"
+ "https://dapp-world.com/course/introduction-to-solidity-Ynws/working-of-traditional-dapps-compared-to-dapps/reading\n\n"
+ "http://www.google.com\n"
+ "https://www.google.com\n"
+ "http://google.com\n"
+ "https://google.com\n"
+ "http://www.google.com/\n"
+ "https://www.google.com/\n"
+ "http://google.com/\n"
+ "https://google.com/\n"
+ "http://www.google.com/index.html\n"
+ "https://www.google.com/index.html\n"
+ "http://google.com/index.html\n"
+ "https://google.com/index.html\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}