import re
regex = re.compile(r"^(?:https?:\/\/)?(?:www\.)?[\d\w\.-]+(?:\.|:)(?:[a-z\.]{2,6}|\d+)\/?.*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("https://regex101.com/\n"
"https://www.variables.sh/complex-regular-expression-examples\n"
"https://search.brave.com/search?q=regex+challenges&source=desktop\n"
"https://web.whatsapp.com/\n"
"https://www.youtube.com/watch?v=fc_RvxTtIwc\n"
"https://text-auditor.netlify.app/\n"
"https://github.com/Dashrath-Sharma\n"
"http://github.com/Dashrath-Sharma\n"
"https://onecompiler.com/javascript/3zqzyu2g4\n"
"http://localhost:3000/\n"
"https://www.codingame.com/clashofcode/clash/report/3342454a92e4c660d772438bac8b2ef73de3c8f\n"
"https://react.dev/learn/thinking-in-react\n"
"https://dapp-world.com/course/introduction-to-solidity-Ynws/working-of-traditional-dapps-compared-to-dapps/reading\n\n"
"http://www.google.com\n"
"https://www.google.com\n"
"http://google.com\n"
"https://google.com\n"
"http://www.google.com/\n"
"https://www.google.com/\n"
"http://google.com/\n"
"https://google.com/\n"
"http://www.google.com/index.html\n"
"https://www.google.com/index.html\n"
"http://google.com/index.html\n"
"https://google.com/index.html\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")