const regex = /^[A-Z]{6}[A-Z0-9]{2}([A-Z0-9]{3})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{6}[A-Z0-9]{2}([A-Z0-9]{3})?$', '')
const str = `DEUTDEFF500`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}