package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.md#.*\)`)
var str = `<!-- Text 1
Text 2
Text 3
-->
<!-- Text 1
Text 2
Text 3
-->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}