$re = '/.md#.*\)/';
$str = '<!-- Text 1
Text 2
Text 3
-->
<!-- Text 1
Text 2
Text 3
-->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);