import re
regex = re.compile(r"\,(?<events>\d+)\]", flags=re.MULTILINE | re.IGNORECASE)
test_str = "[[`Event1`,1435],[`Event2`,78],[`Event3`,142]]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")