re = /\,(?<events>\d+)\]/mi
str = '[[`Event1`,1435],[`Event2`,78],[`Event3`,142]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end