import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.[^\\n]*?)\\[code](.*?)\\[\\/code](.[^\\n]*?)(*SKIP)(*F)|(.[^\\n]*?)\\[php](.*?)\\[\\/php](.[^\\n]*?)(*SKIP)(*F)|:\\(";
final String string = "There is a sad face somew:(here inside this text.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}