re = /(.[^\n]*?)\[code](.*?)\[\/code](.[^\n]*?)(*SKIP)(*F)|(.[^\n]*?)\[php](.*?)\[\/php](.[^\n]*?)(*SKIP)(*F)|:\(/
str = 'There is a sad face somew:(here inside this text.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end