const regex = /^(.*? )?(dog|car|house|work|cat) .*?(dog|car|house|work|cat) .*?(dog|car|house|work|cat)( .*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*? )?(dog|car|house|work|cat) .*?(dog|car|house|work|cat) .*?(dog|car|house|work|cat)( .*)?$', 'gm')
const str = `I always let my cat and dog at the animal nursery when I go to work by car
The dog jumped over the house to get to work
The dog and cat are friends
The dog jumped over the houses to get to work
This sentence has four consecutive words to match cat dog house car`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}